How to set up a catalog menu on the frontend

Hi. When installing the frontend and theme, I cannot configure the menu as in the demo. I must have missed something.



My demo

As you can see, the categories are not displayed after installing the demo data. I tried installing different versions, the result is the same

Hi, volanar!

We use Link lists in the theme. That’s why you should create lists

  1. Navigate to the admin site: Admin > Content > select your store > Link lists.

  2. Click the “Add” button.

  3. Create a list with the name “catalog-menu.”

    • Add parent categories with their permalinks.
    • Set the language.
    • Save.
  4. Create a link list for subcategories.

    • Add the name of a parent category.
    • Add subcategories.
    • Add permalink (/parent/subcategory).

For more detailed steps, you can refer to the documentation here: Managing Link Lists

Feel free to reach out if you have any questions or need further assistance!

1 Like

Thanks for the support. Help me solve another issue. Where can I enable the setting for quick search? It doesn’t work by default

Please explain what kind of quick search you are talking about. Can you attach a screenshot?

By default, this is disabled and I cannot find it in the documentation and in the configuration files where it is enabled or configured.

Hi @volanar ! This feature should work out-of-the-box without any configuration. Do you have any errors in web developer console?

index.js:28 Uncaught (in promise) ApolloError: GraphQL.Execution.UnhandledError: Error trying to resolve field ‘pages’.
—> VirtoCommerce.SearchModule.Core.Exceptions.SearchException: Indexed content search is disabled. To enable it add ‘Search:ContentFullTextSearchEnabled’ configuration key to app settings and set it to true.

‘Search:ContentFullTextSearchEnabled’ configuration key - This is disabled by default. Where can I turn it on?

In platform options, so it depends on your deployment. If you run it from binaries or sourсe code, you can change appsettings.json: vc-platform/src/VirtoCommerce.Platform.Web/appsettings.json at 916ccfbbab68cd7b2cd4994c5a358d684ad6ab81 ¡ VirtoCommerce/vc-platform ¡ GitHub or set environment variable Search:ContentFullTextSearchEnabled in your system. If you use Virto Cloud, you need to add Search__ContentFullTextSearchEnabled to platform.config: vc-deploy-dev/infra/environments.yml at dd94585d7f7430ad51c8d79be8cf7e1ccc691479 ¡ VirtoCommerce/vc-deploy-dev ¡ GitHub

P.S. I created an issue in internal tracking system so theme shouldn’t fail if static content (Page Builder) pages ain’t indexed. This feature disability shoudn’t affect search suggestions for products and categories.

1 Like

Thanks, it helped. My appsetting.json was incomplete